Cómo sumar celdas en varias hojas en Excel

Sumar celdas en varias hojas de Excel

Cómo sumar celdas en varias hojas en Excel

  • Agregar valores de celda única
  • Agregar valores en el rango de celdas

Cubriremos ambos métodos aquí.

Agregar valores de celda única en varias hojas en Excel

datos de muestra 1

=SUM(first sheet name:last sheet name!cell address)

En esta fórmula, los dos puntos indican el rango de hojas. En nuestro caso, vamos a sumar valores en todas las hojas para diferentes empresas. Por tanto, la fórmula será:

=SUM(January:April!B2)
=SUM('Sheet 1:Sheet 4'!B2)

En la fórmula anterior, la celda B2 representa las ventas de la empresa A. Escriba la dirección de celda correcta; de lo contrario, recibirá un error.

  1. Seleccione la hoja en la que desea mostrar la suma.
  2. Seleccione la celda de destino y escriba =SUMA(.
  3. Ahora, seleccione la primera hoja que contiene datos. Haga clic en la celda que contiene un valor.
  4. Mantenga presionada la tecla Mayús y seleccione la última hoja. Asegúrese de que la misma celda esté seleccionada allí. Esto seleccionará todas las hojas en su archivo de Excel.
  5. Haga clic en la barra de fórmulas y cierre el corchete.
  6. Prensa Ingresar.

Cuando haya terminado, use el controlador de relleno para completar la fórmula en todas las celdas.

Agregar valores de celda única en hojas seleccionadas en Excel

=SUM(sheet 1!cell address, sheet 2!cell address, sheet 3!cell address, ...)

Por ejemplo, en nuestro caso queremos mostrar las ventas totales de diferentes empresas en enero y marzo, la fórmula será:

=SUM(January!B2, March!B2)
=SUM('sheet 1'!B2, 'sheet 3'!B2)

Alternativamente, también puede seguir los pasos que se indican a continuación:

  1. Seleccione la hoja en la que desea mostrar la suma.
  2. Seleccione la celda de destino y escriba =SUMA(.
  3. Seleccione la primera hoja y luego seleccione la celda requerida.
  4. Haga clic en la barra de fórmulas, escriba una coma y presione la barra espaciadora.
  5. Ahora, seleccione otra hoja y seleccione la celda deseada. Realice este proceso hasta seleccionar las celdas en todas las hojas requeridas.
  6. Haga clic en la barra de fórmulas y cierre el corchete.
  7. Golpear Ingresar.

Cuando haya terminado, use el controlador de relleno para copiar la fórmula en todas las celdas.

Agregar valores en el rango de celdas en varias hojas en Excel

Datos de muestra 2

Para sumar datos en el rango de celdas de diferentes hojas, utilice la siguiente fórmula:

=SUM(first sheet name:last sheet name!cell range)

En nuestro caso, si queremos sumar notas en todas las materias en todos los semestres, entonces la fórmula será:

=SUM('Semester 1:Semester 4'!B2:E2)

Sumar rango de celdas en diferentes hojas.

En la fórmula anterior, Semestre 1:Semestre 4 representa el rango de hojas y B2:E2 representa el rango de celdas. Hemos utilizado comillas simples en la fórmula porque los nombres de nuestras hojas contienen un espacio.

Agregar valores en el rango de celdas en las hojas seleccionadas en Excel

Para sumar valores en el rango de celdas de las hojas seleccionadas en Excel, utilice la siguiente fórmula:

=SUM(sheet 1!cell range, sheet 2!cell range, sheet 3!cell range, ...)
=SUM('Semester 2'!B2:E2, 'Semester 4'!B2:E2)

Sumar rango de celdas en hojas seleccionadas

La forma más sencilla de hacerlo es seleccionar el rango de celdas de cada hoja por separado. Si agrega el rango de celdas en todas las hojas, puede usar la tecla Shift. Ya hemos explicado los pasos para hacer esto anteriormente en este artículo. Cuando haya terminado, use el controlador de relleno para copiar la fórmula a las celdas restantes.

¿Cómo agrego varias filas en una suma?

Puede agregar varias filas en Excel utilizando la fórmula SUMA. La estructura de la fórmula será =SUMA(rango de celdas de la primera fila, rango de celdas de la segunda fila, rango de celdas de la tercera fila,…). Alternativamente, puede seleccionar el rango de celdas en diferentes filas con el mouse y separarlas con comas.

¿Cómo agrego una suma de varias filas en Google Sheets?

La fórmula para agregar varias filas en Google Sheets es la misma que la fórmula utilizada en Excel. Tipo =SUMA(rango de celdas de la primera fila, rango de celdas de la segunda fila, rango de celdas de la tercera fila,…) y golpear Ingresar. Google Sheets mostrará la suma.

Leer siguiente: Cómo eliminar fórmulas en Excel y conservar texto.

Subir